Do I need to install any of this?ΒΆ

Yes, if any of the following:

  • You need library support for Talon SRX, Talon FX, Victor SPX, CANCoder, CANifier, Pigeon IMU
  • You need to field upgrade Talon SRX, Talon FX, Victor SPX, CANCoder, CANifier, Pigeon IMU, PDP, or PCM
  • You want to use Phoenix Tuner for CAN diagnostics (highly recommended)

Note

PCM and PDP objects are already supported in the base FRC installation. However, Phoenix Tuner is required for setting the device ID, field-upgrade, and Self-test Snapshot.